読者です 読者をやめる 読者になる 読者になる

OS X Mavericks 上で Eclipse 4.4 Luna をアップデートしたらJDK7を要求された

Eclipse 4.4→4.4内でのアップデート. アップデート終了後に Eclipse を起動するようとすると, java version 1.6.8 じゃだめなので 1.7 にして, という警告がでて起動しない.設定 > Java ではJavaプラグインは1.7になってるのだが… 一方, /usr/bin/java など…

svn diff for subversive on Eclipse

Use Team > Compare with ... instead. In addition, Preference > General > Editors > Text Editors > Quick Diff may help.

svn diff for subversive on Eclipse

Eclipseのメニュー(特にTeamあたり)で Diff みたいな単語を探すが見つからない. 実は Compare with ... がそれに相当. また, General > Editors > Text Editors > Quick Diff の設定で, svn working copy を基準にした変化をルーラに表示させることもできる.

Mac で Eclipse PDT (Helios) と XAMPP で PHP の Debug

PHPのdebuggerは敷居が高い(気がする). しかし最近, Eclipse PDT (Galileo)での開発について, XAMPP on Windows (1.7.2)を想定して書かれた, かなりよい本が出ている.Eclipse PDTではじめるPHPプログラミング入門―PHP 5.3/PDT 2.1対応作者: 掌田津耶乃出版社…