読者です 読者をやめる 読者になる 読者になる

Upgrade from OS X 10.8 to 10.9 Mavericks on Macs equipped with X11 and Fink

After upgrading to Mavericks,

  1. You have to reinstall XQuartz as indicated in the warning pop-up even if you already have the newest version of XQuartz installed.
  2. You do not have to recompile fink packages in order to use fink binaries already installed. Some of the packages are forced be removed with "apt-get -f install" to resolve dependencies.
  3. If you wish to "fink selfupdate" or "fink install," you have to "clean upgrade" to fink-0.36.0.

Refs

  1. http://www.jianglai.org/2013/06/17/using-mac-os-x-10-9-mavericks/
  2. http://fink.thetis.ig42.org/download/10.9-upgrade.php?phpLang=en